Switch Virtual Interface (SVI) Layer 3 Interface

Switched Virtual Interface (SVI) is a VLAN of switch ports represented by one interface to a routing or bridging system. There is no physical interface for the VLAN and the SVI provides the Layer 3 processing for packets from all switch ports associated with the VLAN.
SVIs are generally configured for a VLAN for the following reasons:
  • Allow traffic to be routed between VLANs by providing a default gateway for the VLAN.
  • Provide Layer 3 IP connectivity to the switch.
  • Support bridging configurations and routing protocol.
SVIs advantages include:
  • Much faster than router on a stick, because everything is hardware-switched and routed.
  • No need for external links from the switch to the router for routing.
  • Latency is much lower because it does not need to leave the switch
To configure Switch Virtual Interface (SVI) we will use IOSv-L2 on GNS3. How to configure IOSv-L2 on GNS3 for advanced Switching click here.
TASK
  • Create VLANs 10 and 20
  • Configure all IP addresses as specified in the topology picture.
  • Configure SW1 SVI Interface for both VLANs and configure IP address.
  • Configure PC1 in VLAN 10 and PC2 in VLAN 20.
  • Ensure PC1 and PC2 are able to communicate with each other.
We are using Basic Topology for this scenario

Create VLANs
Switch(config)#vlan 10
Switch(config-vlan)#name Management
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name Admin
Switch(config-vlan)#exit
Make Members of Vlans
Switch(config)#interface gigabitEthernet 0/0
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)# no shutdown
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)# no shutdown
Create SVI Interfaces
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#interface vlan 20
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown
Configure PC1 and PC 2 Ip addresses
To configure IP and default gateway in VPCS PCs type ip ip address / slash valeu then gateway
PC> ip 192.168.10.2/24 192.168.10.1
PC ip 192.168.20.2/24 192.168.20.1
Check connectivity

Congratulations: You have configured SVI successfully.

Comments

  1. Hi Suresh, Its a good one and its very easy to understand. Thank you!

    ReplyDelete

Post a Comment