How to Configure Basic Switching in GNS3

While an Etherswitch module does not support advanced layer 2 features, it does allow you to configure basic VLANs, Spanning Tree and other options.
To configure GNS3 EtherSwitching we will use same IOS c3725-adventerprisek9-mz.124-15.T14.bin to download this ios read my How to Configure Router on GNS3 Post
Open your GNS3 and click Edit > Preference.

Click on IOS routers then Click New

Click on New Image Browse your IOS image.

Select IOS image and click Open.

Click Yes to decompress this IOS image.

Click select checkbox This is an EtherSwitch Router and leave other things default.

Change default Ram 128 MiB to 256 Mib and click Next.

Leave default all these things and click Next

Click on Idle-PC finder after calculation of Idle-PC value click Ok then click Finish.

Click Apply and Ok


Now Click Switches Symbol on left side then drag 3 EtherSwitch Router and make this topology. Add links with same port which is showing in this image
NOTE: – FastEthernet 0/0 and FastEthernet 0/1 interface don’t support switching functionality. Use interface from FastEthernet 1/0.
Now right click on Switch and Start all Switches one by one take Console of all switches by right clicking on a switch and select Console.
To create vlans use the command “vlan database” in exec mode
After creating all desired vlans use “exit” to apply the config
To view existing vlans use the command “show vlan-switch brief”

Switch 1
Create Vlans

ESW1#vlan database
ESW1(vlan)#vlan 10 name Management
ESW1(vlan)#vlan 20 name AdminStaff
ESW1(vlan)#vlan 30 name IT
ESW1(vlan)#exit
APPLY completed.
Exiting….

Make Trunk Interfaces

ESW1(config)#interface fa1/0
ESW1(config-if)#switchport mode trunk
ESW1(config-if)#switchport trunk encapsulation dot1q
ESW1(config-if)#no shutdown
ESW1(config)#interface fa1/1
ESW1(config-if)#switchport mode trunk
ESW1(config-if)#switchport trunk encapsulation dot1q
ESW1(config-if)#no shutdown

Create VLAN Interface

ESW1(config)#interface vlan 10
ESW1(config-if)#ip address 192.168.10.1 255.255.255.0
ESW1(config-if)#no shutdown
Switch 2
Create VLANs
ESW2#vlan database
ESW2(vlan)#vlan 10 name Management
ESW2(vlan)#vlan 20 name AdminStaff
ESW2(vlan)#vlan 30 name IT
ESW2(vlan)#exit
APPLY completed.
Exiting….
Make Trunk Interface
ESW2(config)#interface fa1/0
ESW2(config-if)#switchport mode trunk
ESW2(config-if)#switchport trunk encapsulation dot1q
ESW2(config-if)#no shutdown
ESW2(config)#interface fa1/1
ESW2(config-if)#switchport mode trunk
ESW2(config-if)#switchport trunk encapsulation dot1q
ESW2(config-if)#no shutdown
ESW2(config)#interface vlan 10
ESW2(config-if)#ip address 192.168.10.2 255.255.255.0
ESW2(config-if)#no shutdown
Switch 3
Create Vlans
ESW3#vlan database
ESW3(vlan)#vlan 10 name Management
ESW3(vlan)#vlan 20 name AdminStaff
ESW3(vlan)#vlan 30 name IT
ESW3(vlan)#exit
APPLY completed.
Exiting….

Make Trunk Interfaces

ESW3(config)#interface fa1/0
ESW3(config-if)#switchport mode trunk
ESW3(config-if)#switchport trunk encapsulation dot1q
ESW3(config-if)#no shutdown
ESW3(config)#interface fa1/1
ESW3(config-if)#switchport mode trunk
ESW3(config-if)#switchport trunk encapsulation dot1q
ESW3(config-if)#no shutdown
Make Trunk Interface
ESW3(config)#interface vlan 10
ESW3(config-if)#ip address 192.168.10.3 255.255.255.0
ESW3(config-if)#no shutdown
Now Check Conectivity using ping comannd.
ESW1#ping 192.168.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 60/115/252 ms

ESW1#ping 192.168.10.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/35/76 ms
Congratulations: You have configured successfully EtherSwitching. We will discuss advanced switching later using L2IOS.

Comments

Post a Comment